Out with the old Joomla 1.5, In with the new Joomla 3

techgasp

As announced by Joomla, this month the good, old and faithful Joomla 1.5 LTS "long term release" will no longer be supported. Joomla 1.5 was released in January 2008 and was a great joy to work with, like many users we found it to be a friend over the years and a huge improvement over Joomla 1.0 and earlier versions.

Have you upgraded your joomla website! Read more below...

Demo Social Master

Joomla 1.5, the king is dead

The official LTS is currently Joomla 2.5, also with huge improvements over 1.5 version. Work on Joomla 3 as started a few months back but we still have to wait for the official Joomla 3 LTS which will bring huge exciting new features. You can already download and use Joomla 3 "version 3.0.3" short release version, mainly aimed at Joomla enthusiasts and developers.

Should you Upgrade your Joomla 1.5?

YES. If you run a Joomla 1.5 powered website you should upgrade your website to Joomla 2.5 as soon as possible and enjoy all the new features and available extensions. As you probably know, most of your 1.5 components, modules and plugins won't work with Joomla 2.5. But don't see this as a problem, in fact most of these old extensions already have a 2.5 version or there are other better extensions. There are more extensions available for version 2.5 than 1.5. Over time you won't find any extensions or support for 1.5.

TechGasp follows the same principles. Our extensions are 1.5, 2.5 and joomla 3 ready. But starting this month we will gradually launch new versions without 1.5 support. If you still have a Joomla 1.5 powered website you can ask us for upgrade help. Support Request

How about Joomla! 3

techgasp

As mentioned previously, Joomla 3 is still STR "short term release". It's looking great but it's still mainly for experts, fans and developers. Still not advisable to use it in production websites.

TechGasp is here to help

If you need to upgrade your 1.5 joomla website we are here to help and ready to give you a great discount on all our 2.5 ready extensions. Our extensions pretty much cover all bases, are supported, error free, minimal code and have extremely high page load times. You are safe!

Enjoy All our 30+ Joomla Extensions:

Buy all Joomla Extensions

Enjoy All our 30+ Joomsocial Extensions:

Buy all Jomsocial Extensions